Storware Backup & Recovery
    • Can not backup VM on KVM

      Locked
      Virtual Environments 2 10 940

      Hi

      I'm trying to backup VMs on a KVM hypervisor and it fails with the error

      eu.storware.vprotect.engine.exception.ExternalAPIException: No supported VM disks have been found.

      I've tried a VM using raw disks and qcow but always the same error.

      This is with storware version 6.0.0-28 running on Centos 8.

      It can back up VMs on a different Hypervisor that are qcow. Underlying KVM filesystem is xfs and backup destination is an nfs file system.

      Cheers

    • Hello,

      Can you give us information on how you define disks in KVM? Please send a fragment of the disk configuration of an example virtual machine.

    • This post is deleted!
    • @lsroga File upload doesn't appear to work, so I've placed a couple of example disk configurations that fail here

      https://drive.google.com/drive/folders/1LIjwL665X0Az6Mj3DjvBxu34DrBqzO-T?usp=sharing

    • Hello,

      Does this problem still occur?

      If so, I suggest updating to our latest version 6.0 which includes some fixes and improvements regarding KVM.

      Below is a link to our documentation:

      Storware upgrade

      Remember to update both server and node. Before updating, make a backup of your database in case of issues after updating.

    • @lsroga Hi, this was with 6.0.0-28 but I will try to upgrade to the latest version and see if it makes a difference.

      Thanks

    • @lsroga Unfortunately didn't make a difference. It can backup virtual machines on a different KVM Hypervisor but can't back up VMs on it's own KVM Hypervisor. It can also backup the internal DB.

      The error for failed backups is still

      ExternalAPIException: No supported VM disks have been found.

    • @grover please set the server and node logs to debug mode, backup again and then send me the complete logs from /opt/vprotect/logs. Here are the instructions on how to change to debug mode: DEBUG MODE . If you do not want to send logs here, you can send them to my email: lsroga@storware.eu . Please only let me know in your email that you are from this forum thread.

    • @grover I see in the sent logs that you have a CDROM with the centos system image connected to this virtual machine. It's possible that this is the problem. Please disconnect the CDROM drive from the virtual machine, perform inventory synchronization in SBR to be sure and then try to make a backup.

    • @lsroga I disconnected cdrom and ran inventory but still the same issue. I've emailed you the latest logs.

    • adminA admin locked this topic on