Storware Backup & Recovery
    • Issue with setting up Backblaze B2 as a cloud provider destination for backups

      Virtual Environments 2 19 5.2k

      I have entered in what I think are the correct parameters but when I try to test connectivity, it gives an error message "Connectivity test task failed: IllegalArgumentException: The bucket name must be specified when deleting an object". It seems to create a file in the bucket but doesn't remove it.

    • @smmj Hi, can you please send me logs in debug ? When, you enable it try connectivity test again and then send logs. You can download all logs package by webUI (top left corner "Logs", and download all logs on corresponding page)

    • When you say "enable it" do you just mean for me to try to test the connectivity?

    • @smmj enable debug mode for logs

    • Where should I send the logs?

    • @smmj can you share them from OneDrive, Dropbox, or Google Drive ?

    • I have them available via dropbox. What email address should I share them with?

    • @smmj I did not get anything, sadly. If they are small enough to fit in email send them directly. And sorry for inconvenience our forum lack some features like file sharing for now.

    • Sent them as an email

    • @smmj Ok i checked the logs, so we are talking about Backup Destination / object storage / S3-COMPATIBLE and you are using Backblaze. Did you supply bucket name in configuration ?


    • @Argus Yes, I did

    • @smmj Created a new backup destination in object storage with the same info and got the same error when I tried to test it. Seems that the bucket name is correct for when I go into B2, there seems to be files there that were not there before.

    • @smmj Do you have this 2 option enable (and the rest disable) ?


    • The Parallel Download enabled does not appear on the page. I have disabled the rest of the items and it still doesn't seem to work.

    • @smmj The important one is "Path style access enabled" i checked backblaze connection in our internal lab and all seems to work good. It may be a bug in our software. Since the log is telling us nothing we can try a**lyze your database.

    • @Argus Path style access enabled is switched on. When we try to do a test a file does get created in the B2 bucket, but we still get an error.

    • @smmj We can try one more thing, can you please send me database of storware app ? Script to dump it to file is located in /opt/vprotect/scripts/ and result file is saved to /tmp

    • adminA admin locked this topic on